user image

Shilpa
Published in : 2022-02-26

Issue with generating Thumbnails for PDF file format.

Wordpress

I am running one client's website on a Plesk server.

WordPress is not generating thumbnails for PDF files while uploading them from the TinyMCE editor or directly from the media manager. 

After searching more deeply, I tried Regerating thumbnails plugins for them, but it fails and still, the issue is not resolved.

I have installed magic, Ghostscript, and ImageMagick with all the latest versions.

Did I have a mismatch to the versions with my WordPress 5.8 website?

I am stuck up with this issue for the last 3 days, can someone get me out of this trouble?

Comments

Rakshit Date : 2022-03-06

Best answers

34

Best answers

34

Try with Ghostscript v8.70, ImageMagick  v6.5.7

Here WordPress was looking in /usr/bin for the Ghostscript executable. 

By default ./configure command (with no args) installed GS to /usr/local/bin location.

After installing GS to path /usr/bin instead, WordPress was finally able to generate PDF thumbnails!

 

In order to fix the issue hit below commands in a sequence,

Get latest GS 9.19 tar.gz

wget https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs919/ghostscript-9.19.tar.gz

Unzip downloaded file,

tar -zxvf ghostscript-9.19.tar.gz

Navigate to the same directory after unzipping,

cd ghostscript-9.19
./configure --prefix=/usr
make
sudo make install

That's it. Hope this helps. 

Ref: with this thread

Leave a comment

Join us

Join our community and get the chance to solve your code issues & share your opinion with us

Sign up Now

Related posts

Cpanel to Webmin migration 503 error
Publish date: 2021-08-12 | Comments: 4

Tag: Wordpress

[solved] How to change privacy policy text above place order button Woocommerce?
Publish date: 2022-01-08 | Comments: 2

Tag: Wordpress

creating custom gallery
Publish date: 2021-09-12 | Comments: 4

Tag: Wordpress

Add custom fields in user profile and display in Dashboard
Publish date: 2021-07-27 | Comments: 6

Tag: Wordpress

How to display tags on each posts for customized wordpress theme?
Publish date: 2022-02-26 | Comments: 1

Tag: Wordpress

Wordpress update button returns 404 [SOLVED]
Publish date: 2021-06-26 | Comments: 2

Tag: Wordpress

[solved] undefined $post->ID in WP_Query()
Publish date: 2022-01-30 | Comments: 2

Tag: Wordpress

How to run wordpress with different themes in main domain and subdomain?
Publish date: 2022-03-01 | Comments: 1

Tag: Wordpress