user image

Joseph Morgan
Published in : 2022-02-18

tymon/jwt-auth 0.5.12 requires illuminate/support ~5.0

Laravel

Hello everyone, I am facing a problem while installing tymon/jwt-authwith Laravel 9 I am getting this error 

tymon/jwt-auth 0.5.12 requires illuminate/support ~5.0 -> found illuminate/support[v5.0.0,

I tried to use 

composer require tymon/jwt-auth:^1.0. --ignore-platform-reqs

but no change

Comments

Mohamed Atef Date : 2022-02-18

Best answers

51

Best answers

51

for sorry tymon/jwt-auth is not compatible with PHP 8 and to use Laravel 9 you need PHP 8 so, please use lcobucci/jwt instead of tymon/jwt-auth if you want to use Laravel 9 you can install it easily using 

composer require lcobucci/jwt

Note that you might need to upgrade the illuminate/auth to 9 or 8 using 

composer require illuminate/auth:^9.1.0

Good luck

Joseph Morgan Date : 2022-02-18

Thanks this package working fine

Leave a comment

Join us

Join our community and get the chance to solve your code issues & share your opinion with us

Sign up Now

Related posts

Laravel API POST method returns 419
Publish date: 2022-08-03 | Comments: 1
How to get original attribute value in Laravel?
Publish date: 2022-02-23 | Comments: 3