Joseph Morgan

18 Feb 2022

tymon/jwt-auth 0.5.12 requires illuminate/support ~5.0


Hello everyone, I am facing a problem while installing tymon/jwt-authwith Laravel 9 I am getting this error 

tymon/jwt-auth 0.5.12 requires illuminate/support ~5.0 -> found illuminate/support[v5.0.0,

I tried to use 

composer require tymon/jwt-auth:^1.0. --ignore-platform-reqs

but no change


Mohamed Atef

18 Feb 2022

Best Answer

best answer

for sorry tymon/jwt-auth is not compatible with PHP 8 and to use Laravel 9 you need PHP 8 so, please use lcobucci/jwt instead of tymon/jwt-auth if you want to use Laravel 9 you can install it easily using 

composer require lcobucci/jwt

Note that you might need to upgrade the illuminate/auth to 9 or 8 using 

composer require illuminate/auth:^9.1.0

Good luck


Joseph Morgan

18 Feb 2022

Thanks this package working fine

© 2024 Copyrights reserved for